# Table of Contents

1 Introduction .................................................................................................................. 1

2 Learning the Basics ........................................................................................................ 2
   Access to Tutorials ........................................................................................................... 3
   Starting and Closing ModelVision .................................................................................. 3

3 Introduction to Modelling ............................................................................................... 5
   How the Models Work ..................................................................................................... 5
   Model Table Speeds Editing ........................................................................................... 6
   Sections, Maps and 3D Visualization .............................................................................. 7
   What Can Be Modelled with ModelVision? ................................................................. 7
     Single Target Anomalies ............................................................................................. 7
     Special Cases for Demagnetization .............................................................................. 8
     Ellipsoid, Sphere and Triangle Equivalence .................................................................. 9
     Plunging Pipes, Orebodies and Salt Domes ................................................................ 10
     Multiple Source Anomalies ....................................................................................... 11
     Two Layer Depth to Basement .................................................................................. 12
     Tabular Body Depth to Basement .............................................................................. 12
     Regional Cross-Sections from Gravity and Magnetic Data ......................................... 13
     3D Basin Models ......................................................................................................... 14
     More Complex Models ............................................................................................... 14
     AutoMag (ModelVision Option) .................................................................................. 15
     UBC-GIF Voxel Models ............................................................................................... 15
     Interpretive Regional Fields ....................................................................................... 16
   Quality Hard-copy Printing ............................................................................................. 18

4 Preparation for Modelling ............................................................................................... 19
   How ModelVision Works ............................................................................................... 19
   Project Specification ...................................................................................................... 20
   Project Folder Selection ................................................................................................. 21
   Session Files .................................................................................................................. 21
   Units ............................................................................................................................... 21
   Magnetic Field Specification ......................................................................................... 22
   IGRF Calculator ............................................................................................................ 22
   Map Projections and Datums ......................................................................................... 23
   Project Description ........................................................................................................ 23
   Data Loading .................................................................................................................. 24
     Preferred Channel Names (MAG, GRAV) ................................................................... 24
     Sensor Elevation ........................................................................................................... 24
     Synthetic Model Data .................................................................................................. 25
     Import Lines ................................................................................................................. 25
     Import and Export of Grids .......................................................................................... 26
     Extract Data from Grids onto Lines .......................................................................... 26
     Co-sampling Gravity and Magnetic Data ..................................................................... 27
     Topography .................................................................................................................. 27
     Reference Horizon ....................................................................................................... 28
   Grid Utilities .................................................................................................................. 28
   Previewing Your Data .................................................................................................... 30
   Do I Need a Regional Field? .......................................................................................... 31
   Modelling Large Datasets ............................................................................................. 32
   Decimation ..................................................................................................................... 32
5 Section Modelling Methods .......................................................... 36

All Models Are Three Dimensional ........................................ 36
Single Anomaly Targets ................................................................. 36
  Tabular Body .............................................................................. 37
  Forward Modelling of Tabular Bodies ........................................ 37
  Horizontal Polygon Model ............................................................ 41
Polygroup Body .................................................................................. 43
  Special Cases for Demagnetization ................................................ 44
Multiple Anomaly Modelling ............................................................ 45
  Satellite Anomaly Interpretation .................................................... 46
  Improved Separation with Dynamic In-line Filters ....................... 47
Basin Gravity Modelling ................................................................. 47
Petroleum Exploration Sections ..................................................... 48
Geological Section Modelling ......................................................... 49
Drillhole Modelling ......................................................................... 49

6 Working with 2D Regionals .......................................................... 51

Building a 2D Regional ..................................................................... 52

7 3D Modelling Methods ................................................................. 55

Preparation for 3D Modelling .......................................................... 55
  Initialize Your 2D Regional .......................................................... 55
  Select Your Active Modelling Points .............................................. 56
Single Body with 3D Freedom .......................................................... 56
  Forward Modelling ....................................................................... 57
  Inversion Phase ............................................................................ 57
Multiple Bodies with 3D Freedom .................................................... 57
  Forward Modelling ....................................................................... 58
  Inversion ....................................................................................... 58
A 3D Intrusion ................................................................................... 59
  Forward Modelling ....................................................................... 59
  Inversion ....................................................................................... 59
A 3D Sedimentary Basin Problem .................................................... 60
  Section Modelling ........................................................................ 61
  Inversion ....................................................................................... 61

8 Introductory Tutorial ................................................................. 62

Setting up the Tutorial ..................................................................... 62
Tutorial Background ........................................................................ 63
Tutorial Steps ................................................................................... 63
  Step 1 ......................................................................................... 64
  Step 2 ......................................................................................... 64
  Step 3 ......................................................................................... 65
  Step 4 ......................................................................................... 66
  Step 5 ......................................................................................... 67
  Step 6 ......................................................................................... 68
Introduction

This guide provides you with an overview of magnetic and gravity modelling problems that can be solved with ModelVision.

A selection of practical modelling problems is presented to help you understand the depth and range of magnetic and gravity solutions available in your ModelVision licence. Once you understand the powerful set of tools, the range of problems that you can solve is almost unlimited. For example, you could model a proposed mine site from a suite of serial sections. At the other extreme, you can quickly resolve the depth of a magnetic dyke using a simple tabular block model.

In the chapter entitled Introduction to Modelling, you can see the results from a set of practical examples in magnetic and gravity modelling. These problems range from simple depth calculations to modelling of seismic sections.

When you are ready to start modelling, it is important to read the chapter on Preparation for Modelling. Here you learn about project folders, work session files, geophysical units, magnetic field definitions, data loading, regionals and map projections.

In Section Modelling Methods you learn the basics of 3D modelling along individual data lines. This includes sections on depth estimation, basin modelling and specialized body types.

The chapter on Working with 2D Regionals shows how to build a 2D map regional as a precursor to full 3D modelling across a number of lines.

3D Modelling Methods takes you into the advanced realm of precision modelling where every nuance of an anomaly is important to the interpretation.

Take some time to review the ModelVision User Guide, particularly the chapter on “Controlling the View”. It contains many helpful hints and keyboard tips that can improve the speed of your modelling.

ModelVision operates under Microsoft Windows 7 and 8. Within these computer environments the user interface and functionality are identical.
Learning the Basics

ModelVision is a powerful program to use for data display and basic potential field modelling. The guidelines below will assist you operating ModelVision. These guidelines apply throughout ModelVision.

Guideline 1

Data and models can be displayed in a number of windows at any one time. One window (the one with the highlighted banner at the top) is active. You are able to set display and object attributes only within the active window. To make a window active, move the cursor to the window and click the left mouse button.

Guideline 2

Alteration of the display appearance is ALWAYS controlled by pop-up dialog boxes. These are accessed by clicking the right mouse button while the cursor is in the relevant window. Usually a number of sub-options are presented. In some instances, a display may contain multiple ‘tracks’. To control the display attributes of a specific track, position the cursor in the track before right mouse clicking. The dialog appears and has a Configure button that enables additional controls.

Guideline 3

Configuring individual selectable objects such as models, titles, legends, readings etc is done by positioning the cursor over the object and double clicking the left mouse button. In each case a dialog is presented that controls the selected item.

Guideline 4

Standard Microsoft Windows keyboard usage applies for dialog list controls. This means that the SHIFT key in combination with the left mouse button can be used to select multiple list items. The CTRL key can also be used in combination with the left mouse button when selecting non-consecutive items in a list. Refer to the chapter “Controlling the View” in the ModelVision User Guide for additional information.

Guideline 5

Selection of single or multiple graphics objects can be controlled by using the SHIFT and CTRL keys. Select multiple graphics objects with the SHIFT key held down and multiple left mouse button selections. Refer to the chapter “Controlling the View” in the ModelVision User Guide for additional information. An alternative method of selecting multiple bodies is to draw out an enclosing rectangle with the left mouse button held down.

Guideline 6

If selected graphics objects overlap (such as a title box and a body), use the CTRL key and left mouse button to cycle through the overlapping objects.

Guideline 7

All of the window display types in ModelVision present models as they are created and edited. As changes to body shapes are made or new bodies are added, each window is automatically updated to reflect that change.

Six basic window types exist in ModelVision:
• Profile displays (multi-track presentations)
• Section displays (profiles with cross-sections beneath)
• Map displays (contours, stacked profiles, images etc.)
• Perspective views of models, surfaces, drillholes etc.
• Layout display for annotation and printing.

Access to Tutorials

To assist you in learning how to use ModelVision we have provided a set of tutorials on your installation CD. Tutorials comprise documents that explain the operation and steps to follow, plus data that are used in the tutorial exercise. All tutorials are based on real exploration situations in which ModelVision can be used display, model and interpret potential field data.

The tutorials are available in PDF format, which can be installed from the CD or accessed directly from the Documentation folder on the CD. You need to have Adobe Acrobat Reader installed to view and print the PDF files. Open the ModelVision Tutorials.pdf file to access all tutorials.

Tutorial data is available if the ModelVision tutorials are installed from the CD. A total of 70 megabytes of disk space is required to install the tutorial data. As you work through the tutorials, additional storage is required for session, model, grid and exported data.

Starting and Closing ModelVision

You can execute ModelVision in a number of ways but the three easiest methods are:

1. Select the Windows Start button and choose the Programs>Encom Programs>ModelVision option.
2. Double click on the ModelVision program icon on the Windows Desktop. This icon was created during software installation.
3. ModelVision can also be executed by clicking on a session file in Windows Explorer or from the DOS command line using the syntax:

   mvis myfile.ses

   For Windows Explorer to operate you need an association set up in Explorer View>Options>File Types for SES file extensions and the command C:\Program Files\encom\mvis_pro\mvis.exe "%1

Other methods of creating shortcuts to executables are available in the Windows environment. Refer to the Users’ Guide to Windows for additional information.

The main menu items displayed are:

• File - file handling for projects and sessions is controlled using the options on this menu item. Setting of default folders, licensing, printing and exiting are also available.
• Edit - standard Windows editing functions
• View - create displays of data, drillholes and models
• **Layout** - access to the CAD layout window

• **Model** - access potential field modelling controls from this item

• **Filters** - access standard geophysical filtering functions

• **Utility** - obtain project and data statistics, status and default information from this menu item. Data maintenance (delete, rename) of channels, lines and grids plus generation of grids is available.

• **Tools** - control icons, toolbar and operations dialogs

• **Modules** - menu access to the optional AutoMag and UBC Model Mesh Designer

• **Windows** - control the position and selection of windows and toolbars

• **Help** - on-line help and reference facility.

To exit ModelVision, select the **File>Exit** option. You are given the chance of saving the current work in a binary session file. Session files retain all data, models and displays and are useful as a rapid means of returning to the same processing folder when next you use ModelVision.
Introduction to Modelling

Modelling means different things to different people and there are numerous approaches that can be used to interpret the cause of magnetic and gravity anomalies. Some methods are automated and based on simple assumptions about the distribution of properties while others require the development of a geological model.

ModelVision falls into the latter category - you build geological models and compare the simulated responses with the field data. The companion program, AutoMag, falls into the former category – it automates the process but it is tightly integrated with the forward modelling, thereby allowing you to test automatic solutions and make decisions as to their validity.

The concepts embodied in ModelVision have been developed over many years of work on exploration projects involving mineral exploration, petroleum exploration, engineering geophysics and groundwater exploration. Many of the ancillary tools have been added in response to project requirements and requests from ModelVision users.

In this chapter you will learn:

• How the models work.

• How to produce sections, maps and 3D perspective views.

• How to create models of typical geological situations.

How the Models Work

ModelVision is a 3D modelling environment that can be used to build simple high performance geological models or complex multi-body models.

Each model consists of one or more solid objects buried within a uniform earth. Each object has internally uniform physical properties, but the combination of many objects can produce complex models of the sub-surface. Both the magnetic and gravity responses can be computed for the following list of object classes:

• Plunging polygonal prism (including the frustum and pipe bodies)

• Horizontal polygonal prism

• Tabular body and dyke

• Sphere

• Ellipsoid

• Frustum

• General polyhedra
3D view of the different body (object) classes and some composite models built from the basic body styles.

This set of basic 3D shapes allows for the construction of sophisticated models such as 3D mine plans and solid map geology. This flexibility allows you to model anything from a single magnetic anomaly to a complex 3D drill targeting problem.

The helpful interactive body creation dialog makes it easy to visualize the style of body you wish to add to a map or section view.

**Model Table Speeds Editing**

ModelVision is a 3D modelling environment that can be used to build simple high-performance geological models or complex multi-body models.

The Body Parameter table provides quick access to the body properties, active status and visibility during modelling.
When working with multiple bodies in a model, you can use the Body Parameter table to quickly change properties, depths and the active status as an alternative to graphics selection. Double-click on the body number to display the full property dialog for that specific body.

**Sections, Maps and 3D Visualization**

It is useful to develop and visualize 3D models in combinations of sections, maps and perspective views.

Maps are used to provide control over the horizontal distribution and attitude of the individual objects. The perspective view provides a more intuitive view of the shape and proximity of different objects.

ModelVision modelling is always performed with 3D bodies. If you want to model 2D shapes of semi-infinite strike length, such as dykes and channels, you can extend the strike length of the objects. If the strike length is set to a value of 10 times the depth to the body centre, the influence of the body end faces is minimal. There is no increase in computation time as this is controlled by the number of vertices in the object. Large facets are computed directly and not subdivided into smaller facets.

**What Can Be Modelled with ModelVision?**

The following sections discuss a series of geological problems that can be solved using combinations of the various shapes within ModelVision. Response computation can be derived from individual reading located along data lines (with topography), airborne flight lines, at randomly distributed points or at reading locations down drillholes. As can be seen from the following examples, simple objects can be combined to build complex geological models.

**Single Target Anomalies**

Single target anomalies are isolated magnetic or gravity anomalies that are related to a single geological source. It is assumed that there is minimal influence from adjacent geological units, but a curved regional field can be accommodated by the modelling.
Introduction to Modelling

Section, perspective and map views of the gravity and magnetic response of a single vertical tabular body. Note that the line of section is east-west through the centre of the body.

The tabular body is a favourite for many applications because it is well suited to computing the depth and dip of isolated geological objects such as dykes, dipping volcanic units below an unconformity and broad changes in deep basement lithology. Its simple shape makes it easy to manipulate and its response is fast to compute. The tabular shape forms the basis of many automated depth computations and is used in AutoMag.

Limitation: the sharp corners of the upper surface tend to cause depth over-estimation when applied to more rounded targets.

Special Cases for Demagnetization

Example computation for the demagnetization effect on an ellipsoid with a magnetic susceptibility of 1.0 SI
Demagnetization is the term that is applied to the reduction in amplitude of magnetic anomalies caused by high magnetic susceptibility geological units such as banded iron formations. These high susceptibility bodies reduce the intensity of the local magnetic field in the vicinity of the body and thus produce lower than expected anomaly amplitudes. This only becomes a problem when the magnetic susceptibility exceeds 0.1 SI.

Accurate computation of the magnetic field where demagnetization is high is complex and slow relative to the simple case of induced magnetization. For this reason, demagnetization is ignored unless the magnetic susceptibilities are high. ModelVision provides two methods for computing demagnetization to help improve modelling accuracy in these extreme cases.

The sphere, ellipsoid and horizontal elliptic cylinder have accurate analytic solutions for the computation of demagnetization. These body types can be used to determine possible interpretation inaccuracies for high amplitude anomalies.

Approximate integration methods are also available for tabular, polygon and plunging prism models. These responses are computed numerically by subdividing each facet into a series of smaller triangular facets. The reduction in amplitude of the magnetic field is computed at these facets to produce a more precise estimate of the magnetic field at each sensor position.

**Ellipsoid, Sphere and Triangle Equivalence**

The above figure shows the model response for an ellipsoid, sphere and triangular prism. The section view shows the outline of a tabular body to illustrate the difference in interpretation results and the errors associated with making simplified assumptions about the geology. These matches were achieved using inversion to within 1% RMS of the tabular body response.

The sphere, ellipsoid and elliptic cylinder are useful body shapes for checking limits on your interpretation of single target anomalies and analysis of the influence of demagnetization.
Plunging Pipes, Orebodies and Salt Domes

The plunging prism is a powerful tool for modelling the response of targets that have irregular boundaries in a map view (diamond pipes, granite plutons, intrusive plugs etc.). This body type allows you to change the plunge, plunge azimuth, top surface dip and top surface azimuth. This shape allows for non-vertical structures and a slowly changing depth of overburden. By combining many thin plunging polygonal prisms, you can build complex shapes such as orebodies and salt domes.

Example of multiple plunging prism bodies used to model the magnetic response of a variably magnetic orebody. The body colours are modulated by changes in magnetic susceptibility.

Note

The general polyhedra body type can also be used to simulate complex model shapes. The polyhedra can be ‘cloned’ from an existing body (such as a plunging prism) or alternatively it can be created from multiple surfaces such as topography, depth-to-basement or drilled intersection surfaces.
Multiple Source Anomalies

Many magnetic anomalies cannot be interpreted reliably with a simple magnetic source. To understand the response of a specific exploration target, you usually need to model the response from other sources that are of less interest. Until you have modelled all the anomalies, you cannot be confident that you have properly analysed your primary target. Inadequate modelling of interfering sources influences the computation of depth, dip and volume.

The example above shows four different ways to model intrusions truncated by a shallow unconformity surface. Clockwise from the top left corner are:

- Original model
- Regional removal of deeper intrusion
- Modelling of deeper intrusion
- Modelling of deeper intrusion plus outline of original model
Two Layer Depth to Basement

You can compute the thickness of sediments in a two layer case using a polygonal body and inversion. The depths of the polygon vertices are allowed to move vertically within a tolerance range. In this example, the regional, density and basement surfaces were allowed to change until a satisfactory match was achieved. This method can also be applied to magnetic data where the basement is assumed to have uniform magnetic properties.

Tabular Body Depth to Basement

Inversion was applied to the starting model on the left and the body properties of depth, distance, thickness and property were allowed to vary. The regional was also allowed to float. The combination of magnetic and gravity data can provide better results than each method used in isolation.
Regional Cross-Sections from Gravity and Magnetic Data

Regional geological sections can be constructed from gravity and magnetic data, constraining the possible range of solutions with outcrop, drilling and seismic data. These models are constructed with horizontal polygonal bodies. These are assigned long strike lengths to approximate 2D sections, but you can include intrusive bodies of finite strike length within the section. The effective density or magnetic susceptibility of the body is equal to the sum of the properties of the bodies that occupy the same space.

This style of modelling is useful for both mineral and petroleum exploration and is often used to test the plausibility of different geological theories relating to basin structuring and intrusion history.

In the example above, the regional gravity data has a wide sample spacing relative to the aeromagnetic data. In combination with the associated maps and images, geological inference allows us to extract considerable information regarding the distribution of sediments and major lithological changes within the basement rocks.
3D Basin Models

You can build complex true 3D basin shapes by assigning finite strike length to the polygons along each model line, where the strike length is equal to the line spacing. Each polygon is attached to the ground surface. In this way, you can composite a series of different sections to build a total 3D response for the basin. Inversion can be used to reduce the amount of manual modelling that is required.

Additional layers can be added to the basin model with shallower, finite strike length polygons attached to the ground surface. Note that densities are additive in their effect so the shallower polygons normally require a negative density contrast unless there is a density inversion.

More Complex Models

DXF to TKM Converter

3D DXF files can be converted into TKM model files by the DXF2TKM plugin module. It is available within ModelVision from the menu Model > Import > DXF – 3D. This module will create a TKM file that be loaded automatically into ModelVision.
This powerful new capability allows you to introduce complex models from other products and simulate their magnetic and gravity responses.

**AutoMag (ModelVision Option)**

AutoMag depth solutions for the magnetic basement problem. Compare these results with the previous inversion approach.

AutoMag is an automated depth to magnetic basement calculation option (Shi, 1991) that reduces the time required to perform depth analysis over large survey areas. The tight integration of the AutoMag method with the forward and inverse modelling capabilities in ModelVision removes much of the interpretation uncertainties associated with batch oriented methods. Popular methods such as Naudy, Werner and Euler are in widespread use. Results are normally plotted over maps or images but the natural ambiguity of magnetic interpretation (when present with geological noise) often makes these results difficult to interpret. There is no easy way to relate individual solutions back to the original anomaly and the geological cause of the anomaly.

AutoMag allows you to test any solution by converting it to its equivalent model. Selected depth solutions can be converted to solid bodies and then passed to the inversion module for refinement.

**UBC-GIF Voxel Models**

An optional extension for ModelVision makes it easy to prepare and run UBC-GIF, GRAV3D and MAG3D smooth inversions. Refer to the “UBC-GIF Inversion Programs” section of the ModelVision User Guide.

Use ModelVision to generate the initial model for the inversion along with the associated data and constraint files. The solid models in ModelVision are converted to mesh models by assigning properties to each mesh cell that falls inside a body. The density and susceptibility of that body are assigned to each cell.

You can use the Perspective View to display the mesh design before exporting it. The output model of the smooth inversion can then be visualized in the standard UBC tools or Discover PA’s rich range of visualization options to integrate the inversion results with other models and data sets.
The benefits of using ModelVision with the UBC-GIF programs include:

- Easily connect to industry data formats.
- Prepares topographic models.
- Prepares data files.
- Removes the regional field.
- Prepares a starting model.
- Prepares a bounds file (GRAV3D).
- Runs the UBC-GIF programs.
- Allows you to visualize the results with UBC viewer or Discover PA.

ModelVision allows you to integrate geological controls into the UBC-GIF smooth inversion. ModelVision can create and populate the entire model with physical properties based on geological modelling with limited controls.

You can add an unconformity layer to minimize the leakage of high density or susceptibility values into a low contrast domain. This forces the properties to be distributed below the unconformity and subsequently produces more realistic geological solutions.

**Interpretive Regional Fields**

Gravity and magnetic fields normally consist of a combination of short wavelength anomalies of interest and long wavelength regionals. The process of regional removal is subjective (interpretive) and assumes that no part of the regional field is of interest. Defining a regional on a single cross-section is relatively straightforward. Computing a two dimensional (2D) regional is more complex. ModelVision has the ability to do both.
The 2D regional can be derived without modelling and its removal allows you to isolate short wavelength anomalies of interest like that shown in the figure below. This example illustrates the process of extracting an anomaly resulting from a small gravity high that is dominated by the influence of a deep, low density granite. The regional response of the granite is approximated by a 3rd order polynomial.

Example of regional removal from a gravity data set using a 3rd order polynomial. Clockwise from the top left are the Bouguer gravity contours, Bouguer gravity and regional stacked profiles, residual gravity and regional gravity contours.

This technique for separation of local anomalies from a regional field is more effective than convolution filtering which distorts the shape of the target anomaly and thereby renders it useless for direct modelling.
Quality Hard-copy Printing

Example of a Layout window showing the printer page, and various window objects placed on the printer page.

Although you can print any source window to a predefined scale, the Layout Tool is normally used for report quality graphics. Here you can add title information, assign individual scales to source window objects and draw an interpretation overlay. All graphics source windows, including the 3D perspective view, can be rendered in the Layout Window.

You have access to a range of standard drawing tools that allow you to place text, draw polylines, create filled polygons, group and align functions.

You can print to an A4 page through to an A0 page using standard Windows printer drivers.
How ModelVision Works

A full description of how ModelVision works is provided in the ModelVision User Guide but a summary of the data and model storage concepts is presented in this section. Combined with its high performance magnetic and gravity modelling, ModelVision has elements of GIS, imaging, CAD and data processing. It does not compete with specialist packages for any of these ancillary systems, but their provision allows you to view your models in the context of data that has been derived from these other systems.

GIS Characteristics

You can layer vector data such as contours, imported vector files, points or drillholes and overlay them on a bitmap backdrop. Geographic grids, legends and other objects can be added to these layers.

Imaging Characteristics

You can convert floating-point grids into pseudocolour images with highlights generated at various illumination directions. You can also use an RGB bitmap as a backdrop to the modelling.

CAD Characteristics

Each of the window objects that are used in the interpretation can be placed on a layout page for the production of high quality scaled graphics. You can mix graphs with images and contour maps, add some interpretive and title information and send the results to any supported Windows printer.

Data Processing Characteristics

You can apply line and grid-based filters, grid point and line data and numerically manipulate line channels, point channels, grids and drillhole channels.

Data and Model Storage

ModelVision operates on data and models that are stored entirely in memory. Before any operation can be performed, the data must first be imported to memory. This places a practical limit on the amount of data that you can have present while modelling. In practice, this is not a major limitation. If you have 64 Mbytes of free memory, you can load approximately 64,000 line kilometres of aeromagnetic data with enough room to store one model channel.

It is unlikely that you would want to model this much data, so you normally operate on a subset of the line data but perhaps load a background grid for the complete survey area.

ModelVision’s data space is allocated to geophysical data, models and reference data.

**Geophysical Data**

- Lines x, y, z, ch1, ch2, ch3 etc import/computed
- Points x, y, z, ch1 ch2 ch3 etc import/computed
- Grids import/computed
Drill hole x, y, z, ch1, ch2, ch3 etc import/computed

Models

Polygonal cross section
Contour (plunging prism)
Tabular
Sphere
Elliptical
Cylinder

Reference Data

Microsoft RGB bitmap
ER Mapper vector file
Computed objects such as x, y grids, legends
CAD layer

Apart from the ER Mapper vector file, all these data layers reside in memory. As a result, most operations are in real time.

Project Specification

The dialog for entering and reporting the project properties
ModelVision requires you to organize your work into project folders. When you create a new project using the **File>**New>**Project** menu item, a project definition file (MVPROJ.INI) is created in a pre-existing folder. Information specific to the project is stored in the file and updated whenever you exit ModelVision.

The magnetic field parameters are entered manually or via the **IGRF** calculator button. They are maintained for that project. There are default units stored in the MVISION.INI file, accessible to the user from the **File>**Setup menu item. Coordinate projection details are used for export grids that support projection parameters. If you do not require this information, turn on the **Local Grid** option.

### Project Folder Selection

Project details are written to a file called MVPROJ.INI. Each project must be created in its own folder. If you create a project in a folder containing an existing ModelVision project, the details of the previous project are overwritten. MVPROJ.INI contains coordinate projection and data details, a project description, magnetic field details, and default values for bodies and AutoMag settings. Some of this information may also exist in session files (see below).

Whenever a session file is opened, ModelVision performs a compatibility check. It flags any discrepancies between the project and session file settings and allows you to select either the project or session file settings.

### Session Files

Session files allow you to save snapshots of work in progress. All the information in memory and your windows are captured in this file and are restored in a fraction of the time required to load and process the original data. Since the session file is stored in a binary format, it cannot be loaded into a text editor. You can export important information such as data and models to external ASCII files or standard data formats. Save your grids in ER Mapper or Geosoft format.

You can save multiple sessions files either to keep a historical record of your work and/or to save details of work performed on specific anomalies within a project.

---

**Note**

Current ModelVision session files are not compatible with earlier ModelVision version files (pre version 4.0). If you need to access data stored in these files, export the models, grids and line data to any of the supported formats and import them to ModelVision.

### Units

ModelVision uses the following units.

- **Distance** - metres (feet is not supported)
- **Gravity field** - milligal (mgal) in cgs units or \(\mu \text{m}/\text{s}^2\) in SI units. This is referred to as ‘gu’ for gravity units. 1 milligal is equivalent to 10 \(\mu \text{m}/\text{s}^2\).
- **Gravity gradient** - Eotvos units for model computations and units/metre for gradient filters.
- **Density** - \(g/cm^3\) or \(\text{kg}/\text{m}^3\)
- **Magnetic field strength** - gamma for cgs units or \(\eta\)T for SI units
• **Magnetic susceptibility** - cgs or SI units. Note that 1 cgs unit is equal to $4\pi$ SI units.

### Magnetic Field Specification

Magnetic bodies interact with the Earth’s magnetic field to produce an opposing induced magnetic field. The magnitude of this opposing field is proportional to the magnetic susceptibility of the body.

A source body generates different induced magnetizations at different latitudes due to variation in the inclination of the Earth’s field. At high latitudes bodies produce predominantly positive total field anomalies, at low latitudes the anomalies are predominantly negative, and at mid latitudes anomalies are dipolar. In order to correctly compute induced magnetizations, the strength and direction of the primary field must be specified. In ModelVision the local magnetic field is specified as a field intensity with its direction being defined by an inclination and declination in degrees.

If strong remanent magnetization exists in the body, the total magnetization is computed as the vector sum of the remanent and induced magnetization components. Information on remanent magnetization is often not available and pure induction is assumed in most modelling. ModelVision can compute the influence of remanence if the data is available.

### IGRF Calculator

Magnetic modelling in ModelVision requires a specification for the intensity, inclination and declination of the average magnetic field. Only the total magnetic intensity information is available from most aeromagnetic surveys. How do you estimate the inclination and declination? Published maps often have the required information, however it is often out of date.

ModelVision provides an IGRF calculator to estimate the magnetic field parameters. The International Geomagnetic Reference Field (IGRF) is a standard specification of the harmonic component of the Earth’s field. The field values and rates of change vary in strength and direction but these can be derived as functions of space and time. Data provided in ModelVision is for 1970 to the present but pre-1970 data can be supplied if required.
You can activate the IGRF dialog from the IGRF button in the Magnetic Field Parameters dialog (opened through the Model>Magnetic Field menu option) and also from the File>Project Properties dialog. Select a world view map that covers your project area, enter the year of the survey, the survey altitude and then use the mouse to select your survey location. The IGRF parameters are automatically computed and displayed in the dialog. If you need more precision, edit the latitude, longitude directly and select OK to change the magnetic field specification.

Map Projections and Datums

ModelVision stores the map projection and datum information for reference purposes. This information is written to those files that require projection and datum details (such as ER Mapper .ERS header files). The projection information is not used for any internal calculations within ModelVision.

The selection lists for datums and projections are derived from the data files DATUM.DAT and PROJECT.DAT. The format specification for these files is identical to those used in ER Mapper. These files can be edited to remove all datums and projections that are of no interest in your project areas. This reduces the length of the selection list.

Project Description

The project description (60 chars) allows you to save descriptive information that is retrieved each time you open the project folder. The descriptions are saved in the project and session files. They are displayed in the project dialog.
Data Loading

The most common application of ModelVision is to produce geological models that generate responses that match surveyed gravity and magnetic fields. The survey data may be of point, line, grid or drillhole type, each in a variety of possible formats. ModelVision supports the common industry standards for these various data types.

Preferred Channel Names (MAG, GRAV)

Channels of line data can be assigned arbitrary names when the data is imported. ModelVision searches for the names MAG and GRAV in the channel list and makes these the default choices in most dialogs. By naming your input field channels MAG or GRAV, you save time later because the program makes the correct choice of channels for modelling. Use the Utility>Data Maintenance>Line menu dialog to rename your import channels if they do not have the preferred names.

Computed responses are given the default names of GRAV_MOD and MAG_MOD. These preferred names are also detected by ModelVision in various calculations. Use the same naming convention for grid modelling.

Sensor Elevation

The elevation of the magnetic or gravity sensor defaults to zero. If you have a sensor elevation channel in your line data, you can assign this in the Sensor Z channel field of the Model>Line Control dialog. You can use the GPS height of the sensor in a modern airborne survey or barometric elevation in an older survey. In this case, the modelling is performed relative to the sea level datum. Sensor elevations are positive up.

In surveys with a constant terrain clearance you can use the radar altimeter channel as the reference height above a ground level datum. It is preferable to apply a low pass filter to this channel to remove the characteristic noise associated with vegetation interference. If no altimeter data is available, create a synthetic terrain clearance channel in the Utility>Calculator dialog. For a survey this could be:

\[ \text{Elev} = 80.0 \]
Modelling is performed in this case with the assumption that the ground surface is flat and at zero elevation.

**Synthetic Model Data**

It is sometimes useful to prepare synthetic model data to test a particular geological hypothesis or to assist in the preparation of survey specifications. You can generate a set of synthetic lines in the **Utility>Synthetic Lines** dialog by specifying the number of lines, their length, orientation, line and sample spacing. You can also create synthetic readings within artificial or imported drillholes from the **Utility>Synthetic Drillholes**.

Synthetic data is valuable for testing processing steps such as gridding, RTP (reduction-to-the-pole) or upward continuation.

If you have a digital terrain model (DTM) of the proposed survey area, ModelVision provides you with a method for simulating a drape survey across the terrain. After creating a set of lines within the area covered by the DTM, you can resample the elevation grid at each sample location along the line. You can do this using the **Utility>Line/Grid Sample** option. You then assign the resampled DTM as the sensor elevation.

You may want to add a terrain clearance factor using the **Utility>Calculator** option such as:

\[ \text{elev} = \text{dtm} + 80.0 \]

If the terrain is rugged, you can filter the dtm channel with a long wavelength low pass filter (**Filter>Convolution filters>Low Pass filter**) and increase the terrain clearance to ensure that the flight lines don't tunnel through the terrain. You can use the 3D Perspective view to check the quality of your simulated draped flight path.

Once you have created the synthetic flight lines you can build models that simulate the expected geological environment. This process can be used to assess detection limits, flight path orientation, line spacing, ground clearance and the impact of low magnetic latitudes.

**Import Lines**

ModelVision supports a range of line data formats:

- General ASCII flat table with header records (e.g. CSV)
- Geosoft Oasis montaj™GDB database
- Intrepid external data base link
- Geosoft multi-line (XYZ)
- Geosoft single-line (DAT)
- Multiple Geosoft single-line (DAT) files
- ModelVision simple multi-line format with header record (LIN)
- ModelVision simple multi-line flat table with separate header file
- ER Mapper 4 & 5 traverses (ASC, TXT)
- TOOLKIT single line (TK)
AMIRA TEM

ASEG GDF2 format (DFN and DAT)

External link to files of type .LIN

These formats are described in the ModelVision User Guide. If your data is stored in a multi-column table format and each record has a line name identification, the File>Import Data>Profiles>General ASCII Import utility helps you decode the format and import the data.

The external link for ASCII .LIN files also provides a method for sub-setting of large ASCII files. You can select a subset of the channels and a bounding rectangle to filter the input file.

Remember to name the magnetic and gravity channels MAG and GRAV.

Import and Export of Grids

ModelVision can import grids in a range of industry formats. Note that currently ModelVision does not check any projection information available with that grid (e.g. in the ER Mapper grid format).

ER Mapper grids are exported with the projection specifications of the project. The supported grid formats are specified in Appendix A of the ModelVision User Guide.

Extract Data from Grids onto Lines

If you wish to model along a line of section other than your flight line, you can use the traverse tool to draw a line of section through a grid or contour map. After drawing the traverse line you can numerically adjust the start and end coordinates and select the sample interval and grids to be interpolated as line channels.

Dialog for specifying the parameters of a grid traverse

ModelVision can also interpolate gridded data along flight lines. This facility is particularly useful for checking grid accuracy. Gridded data can be sampled back onto the lines from which they were derived, thereby facilitating a direct comparison with the original data.
Co-sampling Gravity and Magnetic Data

Regional magnetic data is acquired by airborne survey while most regional gravity data is acquired by ground measurements. Simultaneous modelling of these two data sets provides much greater geological resolution than is available from modelling either separately. For most model sections, you find that the magnetic and gravity responses are only partly correlated and a valid geological explanation must be found for all anomalous components. With the aid of geological reasoning, the lower resolution gravity data often allows conclusions to be drawn regarding the source of magnetic anomalies that could not be made from the magnetic data alone.

Simultaneous modelling of magnetic and gravity data requires them to be co-sampled along lines. Create a grid of your gravity data and resample it onto the lines of magnetic data using the Utility>Line/Grid Sample menu option.

Example of a magnetic terrain-related anomaly

Topography

The surface of the ground (topographic surface) is important in geological modelling for the following reasons:

- Ground-based measurements are taken at this surface.
- There is a high density contrast and often a high magnetic susceptibility contrast between the air and the rocks at the topographic surface.
- It is a bounding surface for geological models.

The ground elevation channel can be designated in the Model>Line Control dialog. ModelVision expects elevations to be entered as positive values above the elevation reference surface, but the trace of this channel is displayed in the cross-sections with negative values above the reference surface following ModelVision’s positive downwards depth convention. Bathymetry data for display in modelling marine data should be entered as negative values.

ModelVision only provides the ground (or water-bottom) surface as a reference level. These values are not incorporated into the modelling computations. You can, however, digitize polygonal models to these reference traces after adjusting the horizontal and vertical ranges to give sufficient sensitivity. If you make the polygon widths equal to the line spacing, the bodies abut and make a continuous model.
Terrain-corrected land Bouguer gravity values have the gravity effect of the ground above the reference plane already subtracted using an assumed Bouguer density value. Modelling of this data should only refer to any bodies or parts of bodies above the reference plane if their density differs from the Bouguer density. In that case their density contrast should be their contrast against the Bouguer density. In modelling free-air gravity data, bodies should be digitized to the ground surface, given their true density and the background density should be zero. Bouguer correction of marine gravity data adds a correction for the water column equivalent to the effect of replacing the water with material of specified Bouguer density. When modelling data corrected in this way, the water column should be assigned the Bouguer density. Alternatively, free-air data can be modelled by assigning the water column its own density just as in any other component of the model.

**Reference Horizon**

To use a horizontal but non-zero surface as a reference for model computations, a line channel or grid of that constant value can be created in the calculator and specified as the reference surface. This procedure is useful for investigating operations such as upward or downward continuation. If ground elevations are available but sensor elevations are not, a constant can be added to the ground elevation thereby creating a synthetic terrain-draped aeromagnetic sensor elevation channel.

**Grid Utilities**

The Grid Utility tool allows various operations to be performed on one or more specified input grids. These operations include:

- **Classify** – The Classify grid utility enables an input grid to have the value of each cell classified into one of a number of ranges.
- **Clip** – exclude or include the data from a grid defined by an irregular polygonal region or by a rectangular region. The data can be clipped outside or inside the region.
- **Grid to Grid Clip** – allows a source grid to be clipped to the extents of another grid.
- **Fill Holes** – used to replace nulls in a grid by interpolating the surrounding data values.
• **Flip** – the rows or the columns of a grid can be inverted in their location either horizontally or vertically.

• **Merge Grids** – allows multiple grids (overlapping or non-overlapping) to be combined into a single output grid.

• **Replace** – allow specific grid values (such as Nulls or nominated values) to be replaced by another data value or Null.

• **Reproject** – permits the input grid to be reprojected to an alternative Projection and Spheroid/Datum combination.

• **Resample** – grids can be resampled to a new cell size using any of three available interpolation schemes.

• **Rotate** – a grid can be rotated about its defined origin by a specified angle. Interpolation processing is required for this procedure.

• **Shift** – apply an east or northing offset to the origin of a grid.

• **Split** – used for multi-banded grids, this operation outputs separate component grids of the individual single bands.

• **Trend** – produce a trend azimuth grid and trend confidence grid from an input grid. Only available with an AutoMag licence.

• **Volume** – computes and displays the volume between two grids, or between one grid and a constant Z value.

All functions are operated from a common dialog:
In the two Preview panes on the right side of the Grid Utility dialog are Before and After views of the selected grid. As you change the grid selection or the grid function, so the preview panes redraw and update with the changes. Note that the visual changes occur in memory only and are not permanently saved until you specify and save an output grid using the Save As button.

**Previewing Your Data**

The quality of your input dataset influences the reliability of models that you derive to explain it. Therefore, it is important that you preview (and possibly high grade) your data prior to modelling. ModelVision provides a range of filtering, gridding, statistical and display tools that you can use to investigate and preview your data.

You can check data ranges with the statistics tools and inspect profile data for features such as spikes in multi-track displays or in stacked profile windows.

Images of grids may reveal the need to use regional fields in modelling while the flight lines help you to identify appropriate lines for modelling.

Direct comparison of magnetic data with terrain images may enable you to recognize terrain-related magnetic anomalies. With filters such as the first vertical derivative you can resolve variations in source depth with greater sensitivity.
Do I Need a Regional Field?

In the example above, there is an obvious slope decreasing to the right superimposed on the magnetic anomaly curve. Unless you remove this background slope, you cannot accurately model the source of the magnetic anomaly. In this circumstance, a regional would definitely be required.

There is no unique definition for a regional field. It is best described as the anomaly contribution outside the immediate zone of investigation. This may mean contributions from deep sources or other sources located at some distance from the target anomaly. The regional is part of your interpretation.

ModelVision provides four options:

- No regional - synthetic models
- Direct modelling of the regional
- 1D single line polynomial regional
- 2D multi-line polynomial regional.

Synthetic models by definition have no regional and Regional options must be turned off.

If you are modelling only one line at a time, the single line polynomial regional provides a convenient method for approximating the regional. The figure shows an example of a single line regional. On the regional trace, you will notice that small black squares or ‘handles’ are present. The handles can be interactively selected and moved to control the shape of the regional but any change is also controlled by the polynomial used to create the regional surface.

The 2D regional is an advanced application of modelling where the regional magnetic or gravity field is simulated across a number of lines. A smooth 2D polynomial surface is used to represent the regional, where the shape of the surface is controlled from a stacked profile map. See *Working with 2D Regionals* for more information.
Except for synthetic models, you usually require the use of one of the above regional methods. The polynomial regional is mandatory when multi-line inversion is used. For more information on regionals refer to section “How to Use the Regional Field Option” of the *ModelVision User Guide* and *Building a 2D Regional* in this guide.

**Modelling Large Datasets**

ModelVision is designed to be interactive and provides three primary methods for reduction of line modelling time for large datasets:

- Decimation
- Active lines
- Active points.

Your methodology for working with large data sets also has an impact on the total time, but these tools have the greatest impact.

**Decimation**

Decimation is enabled through the *Model>Model Compression* menu option and is applied to both line and grid modelling. If the compression factor is 5, then a model response is computed at every 5th data point for a line and every 5th row and column for a grid. After the model responses have been computed, a high speed interpolator is used to estimate the model results at the intervening locations.

Care is required to ensure that the decimation is not too coarse relative to the features that you are trying to model. Always ensure that your final model is performed at full resolution.

**Active Lines**

Model computations are restricted to a subset of the lines that have been loaded into memory. You can activate one or more lines for modelling in three ways:

- Open a cross-section of a line for modelling
- Menu item *Tools>Active Line>Modelling*
- Menu item *Model>Line Control>Select Lines*

When do you need to activate lines?

- Modelling any cross-section view
- Simulating the response of a model over several lines
Modelling a 2D regional field

Synthetic studies of a complete survey.

**Note**  
Decimation is applied to active lines.

## Active Points

The active point option restricts modelling to a subset of points on a subset of lines. This allows you to focus directly on an anomaly or anomalies within a large data set. The active point dialog is activated from the toolbar and can be applied to a cross-section or map view.

Multiple regions can be activated in this option to isolate noise or irrelevant geological noise. Active points can be used with compression and inversion. By activating and deactivating groups of points, you can work across a large data set by operating sequentially on individual anomalies.

Note that the polynomial regional is not sensitive to active points and is applied to complete lines.

Computation point activity is not restricted to lines. Both drillholes and randomly distributed points need to have their activity status enabled before they are active for response computation.

## Colour Lookup Tables (LUT)

You can build your own colour lookup tables for images and body lithology using the LUT Editor. This new tool can be used to create LUTs for ER Mapper, Oasis montaj™, ArcGIS, MapInfo and Discover PA.
This tool is used with the new lithology colour type for bodies that extends the existing unique colour and colour by property options.

Lithology Colour Coding

Bodies can be assigned user-selected colours and names using a predefined lithology lookup table. The LUT Editor can be used to build your own lithology tables or you can edit those that are supplied with ModelVision. The table is normally selected at the start of a project and used throughout the project.

You can assign lithologies such as basalt, diorite, sandstone, shale, siltstone etc and the colour selector for bodies supports more than 16 colours if required.

3D Model Generator

The 3D Model Generator tool in ModelVision allows the creation of a body given a polygon or multiple polygons and two surfaces which can be grids or fixed heights. Polygon input can either come from an external vector file or by drawing a polygon in the map window. The latter creates a file mv_tmp.tab.
The tool has been designed to run in a "simple" mode where the Top and Bottom surfaces can be set as grids or fixed values and the model is created without any further interaction. However it can also be run in "Wizard" mode where the "simple" data is passed to the wizard but the user has full access to all the features of the Extrusion Wizard for associating additional data such as input density, susceptibility, azimuth and dip and input colour for multiple polygons. The extrusion process can operate both above (+) or below (-) a surface.

An extruded volume is created as a ModelVision .TKM file that is loaded directly into ModelVision or as an AutoCAD .DXF file that is available externally or can be imported into ModelVision using the Model>Import option.

An example of an extruded series of interpreted polygons from a geological map is shown below. In this case an estimate of the depth-to-top, density, susceptibility and thickness of the individual geological regions has been associated with the individual polygonal regions.

Example of extruded objects below a terrain surface
All Models Are Three Dimensional

ModelVision treats all source bodies as three dimensional and model fields are computed as a function of their 3D x, y, z location. You can build geological models from assemblages of source bodies of appropriate type, location, size and orientation. Physical properties such as density and susceptibility are constant within any one body but you can assemble multiple bodies with differing characteristics to represent complex shapes or complex physical property distributions. In all cases, anomaly fields are computed according to the contrast (difference) in physical property between the model value and the specified background value.

ModelVision does not check for intersection of bodies. The computed field from any volume of overlap is the sum of the fields for that part of each of the overlapping bodies as computed individually against background. There are situations where you want to use overlapping or nested bodies (that is, bodies within bodies). Be careful, however, to avoid unwanted side effects in these cases. ModelVision can provide you with multiple map, section and perspective views that allow you to recognize any unwanted overlap of bodies.

Single Anomaly Targets

Isolated anomalies in gravity and magnetic investigations can usually be modelled by simple 3D shapes. Examples discussed in this section include the polygonal cross-section, elliptic cylinder and tabular body shapes. Although simple in shape, they can be used to approximate a wide range of geological situations.

The tabular body can be used to model a dyke or a steeply dipping volcanics unit that has been truncated by an erosional unconformity. The elliptic cylinder is suited to modelling cavities in limestones or lava tubes. The horizontal polygonal cylinder can be used for very simple shapes to complex shapes.

If these models are assigned very long strike lengths relative to the depth of investigations, they can be considered 2D models because the ends of the bodies have little or no influence on the amplitude or shape of the anomaly. ModelVision still treats these as 3D models for the purpose of computation, but only one cross-section model is required to estimate parameters such as depth and physical properties.
Tabular Body

Tabular bodies are widely used in modelling both individually and as building blocks for more complex models. A tabular body has horizontal top and bottom surfaces, parallel sides and a constant, rectangular horizontal section. You can give a dip to the axis of the body in any specified azimuth. Tabular bodies are ideal source models for representing parallel-sided geological bodies such as dykes or planar stratigraphic units such as volcanics or banded iron formations.

The tabular body is probably the most popular shape for rapid estimation of depth, body properties and dip. It is well behaved during modelling with respect to these parameters and it is usually possible to achieve a good match within a few iterations. AutoMag also uses the tabular body as a model for automatic location and depth estimation of isolated magnetic anomalies.

Forward Modelling of Tabular Bodies

Size

To a first approximation, the amplitude scale of a potential field anomaly due to a compact source at depth is proportional to the ‘anomalous’ mass or magnetization of the source. This is defined as the product of its volume and physical property contrast against the background. For deep sources where the width is less than half the depth to the top, you cannot resolve the volume and physical property contrast. In this case you may need to run several models of different physical properties.
Shape

Discrepancies between magnetic field trends and source shape and orientation at low latitudes

The horizontal shape of a tabular body and the orientation of its long and short axes are set according to the anomaly shape and orientation. At low latitudes, however, magnetic anomalies are elongated east-west even for equi-dimensional sources and at mid latitudes the dipolar characteristic of anomalies make it difficult for you to accurately estimate source location and shape. The difference between the magnetic anomaly orientation and the body orientation vary with strike direction, magnetic latitude and remanent magnetization direction.

Depth

Inability of deep sources to match the sharpness of anomalies from shallow sources

Determination of depth to source is a major objective in the interpretation of gravity or magnetic data. None of the model parameters are independent of each other and you need to treat depth as one of a set of source parameters that include size, shape and property.

Ambiguity in interpretation of source body and magnetization dips
Optimum source depth is determined by simultaneously matching amplitude and ‘sharpness’ of an anomaly. Increasing the property contrast of a source increases the anomaly amplitude. Decreasing the depth of a source sharpens its anomaly by increasing the amplitude of short wavelength components more than the long wavelength components. You generally find a limited depth range across that anomaly amplitude and sharpness can be simultaneously matched.

**Dip**

Asymmetry of an anomaly due to a regional gradient can be erroneously interpreted as source dip

Dip determination from either gravity or magnetic data is the least reliable parameter derived from modelling. This problem is not due to a limitation of the modelling algorithm, it is caused by interference from overlapping anomalies and the curvature of any regional field. Dip is determined from the asymmetry of the anomaly and most of the dip information is derived from the anomaly flanks. A small amount of interference with the anomaly flanks can make large differences in the dip determination.

The magnetic case is further complicated by remanent magnetization. The shape of the magnetic anomaly is determined by the vector sum of the induced magnetic field and the remanent magnetization vectors. If remanent magnetization is strong, the resultant direction of this vector can be different to that assumed for the Earth’s inducing field. If this direction is different by 45 degrees, it is probable that the dip is incorrect by at least 45 degrees.

**Depth Extent**

Shallow source magnetic anomalies have diagnostic flanking polarity reversals – in other cases, depth extent can be difficult to interpret

Shallow magnetic bodies of limited depth extent have a diagnostic sharp ring of opposite polarity surrounding the central anomaly. This negative lobe disappears as the depth extent increases. This characteristic does not exist for gravity anomalies.
Depth extent can be modelled but it is not very reliable once the depth extends beyond twice the depth to the top of the body. If the physical property is known, a more reliable estimate of depth extent can be calculated. This latter estimate relies more on the amplitude of the anomaly than on subtleties in shape.

**Inversion of Tabular Bodies**

ModelVision’s inversion is useful in the final stages of modelling after you have achieved a reasonable match between modelled and actual data. Successful application of inversion depends on appropriate selection of the parameters on which to invert and on the application of tight constraints on the bounds for those parameters. For a tabular body, the sensitivity of an anomaly to source parameters as outlined above should be considered in selection of the variables for inversion. If you invert a single profile, you should not specify body strike length or azimuth as free variables as constraint of these parameters requires off-profile information.

**Quick Inversion**

The Quick Inversion utility can produce a tabular starting model as well as a final inversion computation.

To compute a model using the Quick Inversion utility a cross-section view must first be active and a magnetics grid must be open in the ModelVision session. The aim while dragging out a region in a cross-section is to isolate a single anomaly within the input data as illustrated below. If successful a body should be created.

The first stage analyses magnetic grid data to determine a regional and values for susceptibility, position, depth and width around the chosen anomaly. The first stage also turns the ModelVision regional on for modelling.

**Note**

Ensure that the Compute Model toggle button is set to immediate mode to view the results automatically.

_**Drag out a region within the cross-section defining a magnetic anomaly**_

The second stage does an inversion on line data to improve the fit of the model.

If **Auto** is selected and 3 iterations are entered, then the autoinvert will make a series of inversions, with each of three iterations freeing up a progressive number of parameters.

These are:

1. Susceptibility

2. Susceptibility + position + depth
3. Susceptibility + position + depth + width + dip
4. Susceptibility + position + depth + width + dip + extent

The **Auto** Inversion option controls the parameters to be used automatically and the default is set to not invert on the Regional level and any parameters left unchecked. These parameters will remain fixed.

The number of iterations of the inversion can be decreased or increased by adjusting the value in the **Iterations** box.

If a **Manual** inversion is selected then the inversion will run using all the checked parameters listed.

A tabular body will be computed and displayed in the cross-section window

**Horizontal Polygon Model**

A polygonal cylinder used to represent an alluvium-filled depression in bedrock

A horizontal polygon is a body that has a horizontal long axis and a cross-section that is polygonal and constant in shape and size along its length.

The horizontal polygon is an appropriate body for creating models of geological structures that are complex in cross-section but have relatively little variation along strike. In ModelVision polygons are used without limitations on strike extent, body orientation or position relative to a line of section. Additional polygons can be positioned along strike to accommodate along-strike variation or plunge.
The horizontal polygon is used for modelling sedimentary basins, channels, bedrock depth, regional cross-sections and geological units with complex shapes. Note that for this case, the polygonal models are assumed horizontal, but in ModelVision, if the modelling situation requires it, the polygon can be made to plunge towards a specified azimuth.

**Forward Modelling Using Polygons**

You can use a single polygonal cross-section to model depth to an interface. This problem is non-unique but requires only two constraints for solution. You need at least one depth control point and the physical property contrast. Amplitude of relief on the interface is inversely proportional to the physical property contrast across it. To minimize the number of vertices when you first create the model, position them beneath the more abrupt changes in gradient of the field. After creating the starting model, you can use inversion to resolve the depth for each vertex.

**Inversion of Polygons**

Inversion can be used with multiple horizontal polygons, but it must be used conservatively. If the vertices are allowed to float freely during inversion, they can produce extraordinary shapes that have no geological meaning.

Inversion is used in multi-layer basins in the following ways:

- Resolve density contrasts for a given basin shape.
- Make minor adjustments to layer shapes to accommodate small anomaly discrepancies.
- Look for residual anomalies not explained by seismic.

When vertices are allowed to float during an inversion, apply suitable constraints on the amount of movement and limit the direction of movement to either horizontal or vertical during an individual run.
Polygroup Body

This new body type allows you to create complex 3D models using grouped polygonal sections. It replaces the previous snap function and provides a fast, elegant way for managing complex earth models where you need to model the whole sub-surface rather than the anomalous regions.

Major features include:

- Linked vertices to prevent overlap/gaps between adjacent bodies.
- Links maintained during reshape, block shifts and inversion of models.
- Automatic digitizing of new bodies to edges of existing bodies.
- Bodies are grouped together in a section to form a polygroup.
- All polygons in the polygroup have identical azimuths and strike length.

You start with a single polygon and attach new polygons using the new auto-snap function. This feature is easy to use, provides an audible feedback click with each snap and has an edge following capability that makes the creation of abutting polygons very fast. A right mouse click undoes the last point.
Example of complex basement geology using multiple sections

The polygroup body is created on a section and multiple sections can be used to allow for magnetic and density changes that are perpendicular to the line of section. This feature allows full 3D modelling of sedimentary basins over steeply dipping basement geology. You can see a ghost of the adjacent section on the current section for use as a reference when editing the current section.

This new method also makes it simpler to model multiple cross-sections in a mine plan to build complex 3D geological shapes.

Inversion is supported for polygroup bodies where points that are common to two adjacent polygon are moved jointly during the inversion.

Special Cases for Demagnetization

For high susceptibility bodies, modelling without consideration of demagnetization effects is a poor representation of the field that incorporates demagnetization effects.
Bodies of high magnetic susceptibility can produce magnetic fields of such intensity that it is no longer accurate to portray their anomalies as arising directly from induction in the Earth's magnetic field. Rather there is a feedback effect of the body sitting within its own anomalous induction field known as 'self demagnetization'. ModelVision computes demagnetization analytically for the special cases of the sphere and ellipsoid. For all other bodies demagnetization is computed to a first approximation using a surface integral with the body surface broken into facets. Demagnetization applies to all magnetic bodies but is only significant for bodies of high susceptibility (generally with 10% or more of magnetite or pyrrhotite). The threshold above which demagnetization computations are justified depends on:

- The size and susceptibility of the source
- The independent modelling constraints that are available
- The objectives of the modelling

Calculation of demagnetization is enabled in the Magnetic Field Parameters dialog opened using the **Model>Magnetic Field** menu option.

**Multiple Anomaly Modelling**

Geological complexity is such that many gravity or magnetic anomalies overlap with other anomalies due to adjacent, deeper or shallower sources. Ultimately, interpretation of such anomalies does not have a unique solution. Where there is sufficient lateral or depth separation between sources and sufficient spatial resolution in the data, you should be able to derive a credible geological model by simultaneous computation of multi-source fields.
Satellite Anomaly Interpretation

Illustration of the modelling of a low amplitude satellite anomaly where the amplitude of the target anomaly is dominated by the anomaly from a nearby granite.

There are many instances where the magnetic anomaly associated with an interesting geological target is dominated by a strong magnetic anomaly from a nearby magnetic source. In the illustration above, the magnetic anomaly from the granite is larger in amplitude than the magnetic anomaly associated with the exploration target.

It is inappropriate to use a regional to remove the influence of the granite, so it must be modelled. By modelling both magnetic bodies at the same time it is possible to show that the target is well separated from the granite but at the same depth. This conclusion may not be obvious by inspection of the magnetic profile or image maps. Inversion can be used to resolve the best depth and magnetic property estimates for both bodies.

Satellite body detection is very important in the vicinity of mines where there may be reasonable control associated with drilling at the mine site. In this case, you want to model what is known to see if there are any unexplained anomalies present that can be targeted by future drilling.
Improved Separation with Dynamic In-line Filters

In-line vertical gradient filters can assist your depth estimation by simultaneously matching fields and their gradients. These filters highlight inadequacies of models and thereby help you to more rapidly find an acceptable model. The derivatives of a gravity or magnetic field have higher sensitivity to the shallow elements of a model and to details such as body shape. Sharpening filters therefore resolve fine detail in a model and help to separate overlapping anomalies. The most convenient sharpening filter to use in modelling is the first vertical derivative filter that is available from the list of standard filters in the Cross-section Configuration dialog. You can select a filter from this list and that filter of the model input and output is added in a new trace in the cross-section window.

In-line filters are one-dimensional and are computed on the assumption that there is no field variation perpendicular to the profile. While this assumption is generally incorrect, it can lead to an underestimation of the vertical derivative. This, however, is of little concern as the filter still achieves its objectives of sharpening the field variation and providing a valid comparison of the model and observed data.

Basin Gravity Modelling

Cross-section of a depth to basement model over a Tertiary sedimentary basin
Polygonal bodies are well suited to depth-to-basement modelling in cross-section. If suitable measurement profiles do not exist, you may be able to create them by interpolating from a grid onto a traverse or set of synthetic profiles. If there are substantial variations in the gravity values around the margin of the basin you need to define a regional field or create additional bodies to model an heterogeneous basement.

Gravity modelling of petroleum basins may include several horizons with different density contrasts. There is no unique solution that allows you to derive the depth of these horizons without control information. If you have depth control information from wells or seismic data, you can determine the layer densities. If you have density and some depth information, you may be able to derive information regarding the shape of the deepest basement horizon. This method is often used to help with seismic interpretation where basement reflections are often noisy or difficult to interpret.

You can import a depth converted seismic section or geological section as a Windows BMP file and use it as a backdrop in a model section. You can use the mouse to trace the shape of the horizons and build a series of polygonal bodies to represent the basin sediments.

**Petroleum Exploration Sections**

Gravity modelling and inversion of sedimentary sections is used widely in petroleum exploration. The polygroup body makes it easy to build cross-sections and full 3D basin models. The example above illustrates the development of a complex layered model with two salt diapirs. The linking of adjacent layers makes it easy to connect to an existing layer without redrawing.

Assignment of lithology colours and properties makes it easy to apply appropriate colour shading techniques to the geological section.

The salt diapirs truncate the sedimentary layers and are linked to vertices on the layers. Salt diapirs can also be stratified to allow for vertical changes in density.

By using multiple cross-sections, a true 3D response can be calculated for salt domes for precision matching against depth converted seismic sections.
Geological Section Modelling

Where potential field anomalies are reasonably elongate you may be able to model them in cross-section perpendicular to the geological trend. Single profile modelling is often used where model constraints such as a geological section, seismic section, or a line of boreholes are available.

Geological section modelling generally requires more intervention and guidance from geological hypothesis than does the basin modelling described above. Geological section modelling is well suited to investigation of multiple geological hypotheses. For example, a negative gravity anomaly can be explained by a granite or basin. In these cases, models that do not fit the data can be as informative as those that do.

The combination of magnetic and gravity data with other constraints such as seismic is a useful geological tool when looking at large scale geological processes. Limited control information from drilling or seismic can often be tied to the magnetic and gravity data along the section and then extended through geological interpretation of the associated magnetic and gravity maps.

Drillhole Modelling

ModelVision can be used to compute the response of reading in drillholes, even if the hole passes through simulated bodies. Drillhole data can be imported (refer to “Importing Drillhole Data” in the ModelVision User Guide) or you can create artificial holes from the Utility>Synthetic Drillhole option. A synthetic drillhole can be used to test a modelling scenario and can then be applied to designing the location and orientation of a proposed drillhole.

Drillhole readings can have the East, North, axial, total and vertical magnetic components computed. For gravity, complete tensor calculations can be specified. Display of drillhole data can best be displayed in a 3D perspective with reading vectors indicating the orientation and strength of the computed magnetic vector. Alternatively, a colour modulated ribbon can be used to visualize the direction and strength of the resultant vectors.
3D ribbon and section representation of drillhole magnetic responses
6 Working with 2D Regionals

The calculation of a two dimensional regional is required as soon as you want to model multiple lines simultaneously to resolve the horizontal and vertical extent of a complex anomaly. It is often a difficult task to directly model the two dimensional regional magnetic or gravity field. A 2D polynomial representation provides an efficient method of removing the long wavelength components of potential fields in the modelling process.

ModelVision introduces a new way of working with 2D regionals by allowing you to control the shape of the regional surface in a stacked profile map window.

What is a regional field? The simplest answer is "the long wavelength components that you do not want to model". There is no formal approach to regional calculation. It is a subjective part of the interpretation but the assumed long wavelength characteristics of regional fields allows us to use a 2D polynomial to approximate their shape. This polynomial has the form:

\[ R = a + bx + cy + dx^2 + exy + fy^2 + gx^2y + ixy^2 + jy^3 \ldots \]

The polynomial defines a smooth surface where the order of the polynomial is determined by the maximum power of the x and y terms. The complexity of the surface increases with increasing order. A constant base level shift is equivalent to \( R = a \), while a dipping planar surface is defined by \( R = a + bx + cy \). The maximum order that you can specify is 10, but in general, you should not use orders above 3 for modelling unless you are using the regional as an interpretive tool over a large area.

Earlier (see Multiple Anomaly Modelling) there is an example of the use of a regional as an interpretive tool for isolating short wavelength anomalies from a high amplitude regional background. The regional separation method is an alternative to high pass filtering techniques for isolation of shallow source anomalies.

It has two major advantages over filtering techniques:

- It provides effective geological control.
- It is open and subject to critical review by others.
- It does not distort the residual anomalies as much as a filter.

![Example of an inappropriate 5th order polynomial fitted to data from three lines. Contour interval = 50000 nT The side wings occur outside the area of the control points.](image)
There are some undesirable effects of polynomials that you must be aware of when modelling. A polynomial can behave in an extreme way beyond the edge of your control points. Make sure that you have adequate control across the area of interest. In the example above the polynomial matches the field data along the three lines, but rapidly changes shape away from the control points (squares). For this case a 1st order or 2nd order polynomial is sufficient to define the regional field over the area of the three flight lines.

If you use an order that is too large for the surface that you are trying to represent, it may sag or bulge between your control points. You may not see this clearly in a stacked profile map, but it can be seen in the surface that is generated directly from the polynomial.

**Building a 2D Regional**

Regional modelling must start with the selection of lines of data that is used to control the shaping of the regional surface. A subset of the points from the lines is used to create an initial surface by least squares fitting of the polynomial equation. Once the surface has been computed, the original data is no longer required as the new control point handles are used to shape the surface.
There are two ways to select the lines that are used for the regional. One is from the active line toolbox while the other is from the regional control dialog. You can access the dialog from the map dialog or **Model>Edit Regional>Magnetics** menu.

The Active Line toolbar allows you to graphically select the lines you want to use to control the regional surface. The **Active Lines** button in the dialog requires you to select lines by name from a drop down list. After you click the **Regional** button in the Active Line toolbar, drag the mouse across the lines that you wish to activate for regional modelling. You can do this multiple times, but you must first select the **Regional** button each time.

Following completion of your selection, choose the order of the polynomial and click on the **Compute from Data** button. Close the dialog, add the regional channel to your stacked profile map view and turn on **Regional Fixes** in your map control dialog.

![Stacked profile map of the TMI and regional channels, plus regional fixes or "handles". The handles are used to change the shape of the regional surface. 3D perspective of the TMI grid and regional field generated from the 2D polynomial surface.](image)

The regional control boxes are manipulated in similar fashion to the way you would in a cross-section view. In map view, however, you must move the handles in a direction perpendicular to the flight line. In the example above, every second or third line has been chosen to provide control across the area of the project. These results show the final fit after moving the control points until a visual best estimate was achieved. The 3D perspective view helps visualize the two surfaces together. A contour map of the regional grid is also a good guide to the shape of the surface. This is best displayed in a separate map view to avoid clutter in the stacked profile control window.
You can create regional and residual grids with the **Generate Regional Grid** and **Generate Residual Grid** buttons in the regional control dialog. You must have a grid of the field data in memory first to generate a residual grid. If not you can generate the grid from the menu item **Utility>Grid**. Make sure that you select **Use seed grid** for best presentation of the polynomial grid. This ensures that the polynomial is calculated where the grid is not set to null.

The regional can be used during inversion, but only the first three terms of the polynomial can be modified during inversion (\(a + bx + cy\)). This effectively allows you to change the level, slope and azimuth of the initial surface. If more adjustment is required, this must be done manually with the fix points.

![Inversion dialog with regional level and slope as free parameters](image)

When you have positioned your control points you can change the polynomial order and select **Compute from Fixes** in the regional control dialog. Make sure that you use the lowest order polynomial required to represent your regional surface.

You can convert your fix points to data points that can then be gridded for use as a fixed surface regional. You need this option occasionally when the polynomial cannot adequately match the rapid changes in the inferred regional field. This is more likely to happen with magnetic data on the north or south side of an anomaly. The polynomial may not be able to adequately match the shape on both sides. Select **Use grid** in the regional control dialog rather than polynomial computation to provide a fixed regional as the basis for further modelling.
3D Modelling Methods

A model that approximately matches a complete anomaly is likely to be more reliable than one that matches only a single profile through that anomaly. Detailed modelling studies should therefore focus on matching complete anomalies.

Preparation for 3D Modelling

The modelling of a potential field anomaly is a complex problem that requires a flexible strategy to efficiently achieve a result. Before starting to model, the data should be inspected as stacked profile displays and as grid images. These allow you to:

- Recognize problems in the modelling.
- Decide if a regional field is required.
- Decide on the number, type, extent, location and orientation of the starting model bodies.

Initialize Your 2D Regional

By inspecting the data it should be possible to decide approximately what order of polynomial is required to represent the regional field and on what lines the regional is best defined. The regional field is defined in the Edit Regional dialog accessed from Model>Edit Regional>Magnetics (or) Gravity. Having selected the active lines and the order of polynomial, the regional coefficients are initially computed from all the data on those lines.

Each line designated as active for computing the regional has several samples of the regional assigned to it. These samples can be viewed and manipulated in either cross-section or stacked profile displays. The samples have to be adjusted to represent the interpreted regional field and generally require further adjustment throughout the modelling process. The order of the regional field and the active lines on which it is computed can be revised at any stage as necessary.
Select Your Active Modelling Points

If you need to focus on a subset of the map area it may advantageous to temporarily restrict the model computations to that region. The Active Point button on the Model toolbar allows selection of a subset of points in either map or cross-section view. Null values are assigned to non-active points along the lines included in the modelling. Active point selection should extend sufficiently beyond anomalies to allow interactive editing of the regional field. Active point selection is of greatest advantage in inversion as it reduces any sub-sampling required to cut the number of points below the 600 point limit for inversion.

For extensive modelling of a selected region, it may advantageous to create a new session file in that the data is clipped to that area. Clipping to an area makes your session files smaller and makes grid generation and display faster and easier.

Hint

Before clipping, delete any lines that do not pass through the area as deletion of complete lines is much faster than point-by-point clipping.

Single Body with 3D Freedom

A discrete anomaly due to a discrete source provides the simplest modelling target. Not all discrete anomalies, however, are simple to model, and modelling may reveal that an apparently simple anomaly is in fact due to a complex source distribution. For a single body model, it may seem that modelling of a single profile through the peak and/or trough of the anomaly is sufficient. Single profile modelling does not, however, supply reliable estimates of position of the body perpendicular to the profile or its strike azimuth and extent. A model developed to simultaneously match the complete anomaly sampled on multiple lines may vary considerably from models derived to match only a single profile.

Isolated gravity anomaly and matching model of an elliptical cavity
Forward Modelling

ModelVision can update a modelled response by operating in either manual or immediate mode. Modelling with a single body is generally best done in **Immediate Mode** as there are few changes to be made to the model between computations. Furthermore, because there are so few parameters to be optimized in a single body model, there is no need to compute the field at a large number of stations. You only need enough active lines and points to represent the anomaly and to honour the high gradients regions. With the small number of model variables you can quickly develop an approximate model, adjust the regional field as necessary and design an inversion best suited to fit the model.

Inversion Phase

Inversion should be used to tidy up the model once you have embedded your geological concepts in the model. Inversion should start from a reasonable model match to the data. Free those variables that are appropriate and set limits that constrain the inversion within a geologically acceptable range.

Inversion can still be made an interactive process by proceeding in small steps, revising the free parameters and their tolerances between steps, adjusting the regional and the inversion target RMS, and rejecting unwanted developments in inversion of the model.

An inversion that cannot find an improved match or that is converging too slowly may be reinvigorated by temporarily switching off some of the free parameters. Inversion should be guided more by geological interpretation of the model as it viewed in the displays than by the possibly misleading statistic of reduced RMS difference value.

Multiple Bodies with 3D Freedom

Complex magnetic anomaly due to a multi-body source and the modelled field

Modelling of multi-body problems is more complex than modelling of single body problems as there are more variables to resolve. For adjacent bodies, much of the problem may be to resolve those parts of the field variation that are due to those bodies. These problems typically require more geological consideration in establishing a starting model than do single body problems.
Forward Modelling

Unless multi-body anomalies are well separated it is necessary to develop a model using forward modelling before any inversion can be attempted. This conceptual stage of the modelling is critical in obtaining a sensible final model. If there is considerable geological uncertainty about the anomaly sources, it may be possible for you to develop several alternative starting models. Each forward model ends up with a different solution after inversion. The results of the different inversions along with geological reasoning can be used to decide on the most probable solution.

Inversion

Inversion of multi-body anomalies needs careful control as ambiguities in matching the data rise exponentially with the degrees of freedom introduced by adding new bodies to the model. If inversion is not well constrained, bodies introduced with the intention of explaining particular anomalies or parts of anomalies may shift considerably during an inversion to where they can make a greater contribution to reducing the RMS difference.

Before starting a multi-body inversion it is essential to carefully inspect the residual mismatch of the initial model and consider how the inversion process is likely to proceed in reducing the mismatch with the given degrees of freedom and tolerances. There may be many options to reducing the RMS mismatch that are not geologically acceptable. If the inversion does not proceed along an acceptable path, it should be halted, the model reset to its state before that inversion run, and the inversion parameters and/or the starting model adjusted to design a more appropriate solution.

Multi-body inversions are best done in a piecewise manner. Obtain an approximate match to the anomalies and step through each body or tightly clustered set of bodies by freeing a few parameters each time.
**A 3D Intrusion**

This example contrasts the results from modelling along a single terrain following profile with a full 3D inversion that uses the data for all lines that are influence by the magnetic anomaly. The magnetic anomaly is caused by a small igneous body in an area of rugged terrain.

**Forward Modelling**

The initial tabular body model is positioned beneath the line with the largest anomaly and assigned a short strike length. The stacked profile map shows a good match on the main profile, but a poor match to the adjacent profiles. The final match on the single profile was achieved by inversion and would be judged quite successful if considered alone.

**Inversion**

Stacked profile plot of the model match to the complete anomaly and a perspective view of the difference between the models.
The initial model developed on the single profile was sufficient as a starting point for inversion of the complete anomaly. In this inversion, all parameters were set free to vary. The flight lines are only 100 metres apart and tolerances of 100 metres were placed on all spatial parameters except the depth extent that was given a tolerance of 10,000 metres. The tolerance on susceptibility was raised to 0.1 SI as this is a strongly magnetized source.

The inversion easily decreases the RMS difference below the initial 2% target and the RMS target value reduces to 1% to further improve the model match to the data. The second stacked profile display shows the success of the model in matching the complete anomaly. The perspective display illustrates the significant difference that is obtained between the model developed to match a single profile and the model developed to match the complete anomaly. This difference exists despite the fact that the anomaly is recognized mostly on a single profile.

A 3D Sedimentary Basin Problem

The negative gravity anomaly shown is due to a Tertiary sedimentary basin beneath a thin veneer of cover. The steep gradients on the western side of the anomaly are interpreted to be due to a basin-bounding normal fault and the more gentle gradients on the eastern side of the anomaly suggest that the basin is a half-graben. A set of regularly spaced parallel model sections was generated using the Utility>Synthetic option and the gravity anomaly was interpolated onto those profiles as the input channel for modelling.

A density contrast of 0.4 g/cm³ was interpreted from geological hypothesis of the basement and basin fill material. Polygonal bodies were generated on each profile with width equal to the profile spacing so that they form a continuous but non-overlapping model. The bodies are flat-topped at a depth of 20 metres to represent the thickness of the blanket cover in the area.
Section Modelling

The central profile was modelled first, followed by adjacent profiles to successively extend the model towards the ends of the anomaly. In each case individual profiles were matched by adjusting only the body beneath that profile. In this first pass, the models were edited manually in immediate mode. As an approximate match was achieved on each profile that profile was switched to be inactive for modelling, and the body was cloned and moved in the map view to provide a starting model beneath the next selected profile. Once the complete anomaly had been modelled in a first pass all lines were activated and the model was recomputed.

Inversion

Model mismatches displayed in a stacked profile map of observed and modelled gravity were used to select bodies to edit in an iterative development of the model. After the initial pass the model was developed by inverting on the horizontal and vertical positions of the vertices of the base of the model, each constrained within tight bounds. Strike cross-section and perspective displays were used to ensure that there were no unduly abrupt discrepancies between adjacent model sections.
This tutorial is to illustrate the various presentation formats available in ModelVision and to introduce the concepts of multi-line displays and modelling. Geologically, the area to be studied is complex with a number of steeply dipping interbedded volcanics trending NNE to SSW. In some instances, the units are faulted, typically with NE–SW trending structures. Granitic intrusives are evident within the data and these are typified by low magnetic responses. Surrounding these intrusives are magnetic aureoles and demagnetizing affects associated with intersected volcanics.

The aim of this tutorial is to identify and investigate a specific anomaly that has been isolated by regional geochemical surveys and which lies adjacent to a granitic margin. Nearby are known sites of tin deposits and base metal occurrences.

### Setting up the Tutorial

Initially, ModelVision requires a project to define location, magnetic properties and a description of the work. ModelVision stores project information in a file (MVPROJ.INI) which resides in the project directory. Before any data can be imported or a session with ModelVision is commenced, a project must be created.

Select the File/New/Project option and enter the information as required. Initially, select the Browse button and navigate to:

C:\Program Files\Encom\Mvis 15.0\Tutorial\Tute6

It is important at the commencement of a project that you know the location of the data to be used in the session. You can enter the project datum and projection information plus you can supply the location to derive the local Earth’s magnetic field using the IGRF tool as shown in the image below (refer to Magnetic Field Specification and IGRF Calculator).
Tutorial Background

Note

In DEMO mode you cannot import your own data. You can, however, load one of the supplied binary session files which contain data. For access to the tutorial you are required to load a session file.

The data file for this tutorial was acquired from a small airborne survey flown in 1989 in southwestern New South Wales (near West Wyalong). This survey data has been acquired with traverses that are oriented northeast to southwest with line spacing of 1200 metres (only every fourth line has been retained for this tutorial). Within the data file are Australian Metric Grid (AMG) coordinates (using AMG Zone 54), Fiducials, Magnetics, Altimeter and the spectrometer channel for Potassium (K40). The survey was over relatively flat grazing and intensely cultivated agricultural areas. Known granites, volcanics and metamorphosed units predominate in the area with some minor basic intrusives and dyking. Extensive structural deformation and faulting exist in the survey coverage.

Tutorial Steps

The following tasks should be undertaken for this tutorial:
Step 1

Load the data with the File>Import>Profiles>Sep. Header (HDR & LIN) option. The data is located in:

C:\Program Files\Encom\Mvis 15.0\Tutorial\Tute6

The import data file is called TUTE6.LIN but the Separate Header option uses the TUTE.HDR file. This import file format illustrates how large multi-column data files can be loaded without extensive editing of the data file. The header and data file appear as below:

Header File

LINE X Y FID MAG K40 ALT

Data File

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
<th>FID</th>
<th>MAG</th>
<th>K40</th>
<th>ALT</th>
</tr>
</thead>
<tbody>
<tr>
<td>1201</td>
<td>489435</td>
<td>6259404</td>
<td>18612</td>
<td>58158.1</td>
<td>91</td>
</tr>
<tr>
<td>1201</td>
<td>489415</td>
<td>6259397</td>
<td>18613</td>
<td>58157.8</td>
<td>81</td>
</tr>
<tr>
<td>1201</td>
<td>489396</td>
<td>6259390</td>
<td>18614</td>
<td>58158.4</td>
<td>72</td>
</tr>
<tr>
<td>1201</td>
<td>489377</td>
<td>6259384</td>
<td>18615</td>
<td>58159.2</td>
<td>70</td>
</tr>
<tr>
<td>1201</td>
<td>489358</td>
<td>6259377</td>
<td>18616</td>
<td>58159.3</td>
<td>68</td>
</tr>
<tr>
<td>1201</td>
<td>489338</td>
<td>6259371</td>
<td>18617</td>
<td>58159.7</td>
<td>74</td>
</tr>
<tr>
<td>1201</td>
<td>489319</td>
<td>6259364</td>
<td>18618</td>
<td>58158.5</td>
<td>80</td>
</tr>
<tr>
<td>1201</td>
<td>489300</td>
<td>6259357</td>
<td>18619</td>
<td>58157.8</td>
<td>77</td>
</tr>
<tr>
<td>1201</td>
<td>489280</td>
<td>6259351</td>
<td>18620</td>
<td>58156.4</td>
<td>74</td>
</tr>
<tr>
<td>1201</td>
<td>489261</td>
<td>6259344</td>
<td>18621</td>
<td>58155.4</td>
<td>70</td>
</tr>
<tr>
<td>1201</td>
<td>489242</td>
<td>6259337</td>
<td>18622</td>
<td>58153.9</td>
<td>66</td>
</tr>
<tr>
<td>1201</td>
<td>489222</td>
<td>6259331</td>
<td>18623</td>
<td>58153.2</td>
<td>67</td>
</tr>
</tbody>
</table>

After loading the data file, examine the data ranges and statistics of the channels when the statistics dialog opens at the end of the import. You can analyze the statistics of any individual line by double clicking on the nominated line.

Step 2

ModelVision then opens a dialog for selection of a channel for a stacked profile map display. Use the View>Map>Stacked Profiles option and select the MAG data channel. Once a map is presented you can adjust the vertical scaling to highlight features in low gradient areas. This is done by selecting the Layer Table button in the main toolbar to display the Map Layers table and then click on the Stacked Profile layer in the table with the right mouse button to select the Configure pop-up menu option. Edit the vertical scaling and highlight features accordingly.
Dialog for a Stacked Profile map and the display created

From regional geochemical sampling, the location of an area with anomalously high tin and base metal associations is known (see above). The anomaly correlates with a magnetic trend produced by volcanics and was covered by the airborne survey along line 1500.

**Step 3**

To prepare line 1500 and the anomaly for modelling, it is necessary to setup the fields in the **Model>Line Control** dialog. Assign the field Mag to the **Input Channel** and use the altimeter channel ALT for the **Sensor Z channel**. When you use the altimeter channel, the model depths will be in metres below the ground surface rather than absolute elevation above sea level.
There is a broad regional background trend superimposed on the data so we will need to remove this from the data with the regional modelling tools. In other circumstances, a two-dimensional regional surface can be created and used for multi-line modelling. Refer to the sections on Working with 2D Regionals and Building a 2D Regional for a description of this approach.

Check the Use Regional checkbox and then activate the Compute Regional button. Using the Active Lines button, nominate line 1500. Once selected, press OK and click the Compute from Data button using a polynomial order of 1.

Regional specification for the selected line (1500)

Step 4

With the regional created, you can now display line 1500 with a track beneath to be used as a cross-section below the flight line (use the View>View X-Section option). The displayed dialog allows you to select line 1500 from a pull-down list. Note also that the dialog enables magnetic modelling on the line and uses the regional in the computation of magnetic body responses.

Nominate the line (1500) and specify magnetic modelling using a regional

Once specified, click the OK button. Line 1500 is displayed in a profile window with a cross-sectional area beneath. This area is used to create and edit the magnetic model. The model response is superimposed on the regional trace (indicated by three regional 'handles').
The location of the magnetic anomaly is at the left margin of the profile. In preparation for modelling, you need to zoom into the anomaly. You also need to instruct ModelVision that only this anomaly is to be modelled and not the whole profile.

**Step 5**

You can zoom into the target anomaly by using the zoom button, but in this case we will set the Zoom range manually. Use the right mouse click to access the **Configuration>Track1>Horizontal Range** dialog. Specify the Min and Max range of the **Distance Along Profile** to be between 0.0 and 5000.0.

You may wish to adjust the Z range also to use more of the space provided. To adjust the amplitude of the profile right mouse click on the top half of the x-section window and for **Track 1** select **Fit Vertical**.
Make the target anomaly active for modelling and inversion by using the **Active Points** button. Select the **Draw Profile Region** button and position the cursor in the profile window at the start of the area to be modelled. Click the left mouse button and drag an area along the profile for modelling. Ensure the complete anomaly is defined with any side lobes that may affect the source modelling.

After the bounding lines of the active region have been defined, release the mouse button and you will notice the model response curve changes colour.

**Step 6**

To create a model and compute a magnetic response, select the **Create Body** button. As the geological source is not defined, the simplest body type should be used initially. From the Create Body dialog, select the **Tabular** body.
Note that the dialog displays the current default properties that will be assigned to the body and a preview of the body style. Once the tabular body has been selected, position the cursor in the profile cross-section, click the left mouse button and drag a rectangle that will form the body outline. When the button is released, the body is created.

You can display the magnetic response due to the created tabular body by clicking on the Compute button.

Only the response along the nominated active points of line 1500 is computed as no other readings in the dataset have been selected as active. To adjust the display depth for the x-section window right mouse click in the bottom half of the display and select the Track 0>Vertical Range pop-up menu option that appears. Adjust the maximum Z Range to 2000 m.

![Computed response of the tabular body with regional and observed data](image)

**Step 7**

Initially, the body location and orientation is unlikely to be correct for a match between the computed magnetic response and the observed data. You can edit the body, magnetic susceptibility and regional until you get an approximate match between the model response and the original data. After each edit you can force ModelVision to update the computed response by toggling the Manual/Immediate mode of computation.

The tabular body can be positioned by selecting with the cursor and locating as appropriate. Its width can also be modified interactively by selecting a corner handle and dragging. You need to have ModelVision in the Pointer mode for these operations (select the Point icon or button). By using the Reshape button you can edit the dip of the body.

Modify the location and orientation until there is a close match to the anomaly shape. You will also need to adjust the magnetic susceptibility to obtain an amplitude match. Note that there is a level shift between the observed and theoretical traces. You can select the left had regional handle and drag it down so that the shift is minimised. The fastest methods of removing the level difference and improving the model fit is to use inversion.
The use of inversion in ModelVision is a powerful tool for rapidly refining models.

To initiate inversion, select the **Tools>Inversion** option (or click the right mouse button when the cursor is in the ModelVision screen window). The Inversion toolbar is displayed and can be positioned on the screen.

Note that you are using standard inversion rather than join inversion for this tutorial.

The tabular body type is defined by a set of parameters, each of which can be freed during inversion. The more parameters that are set free, the easier it is to get a match with the field data. This is not generally the best approach because the smallest number of free parameters provides the optimum approach. This process lets you evaluate the maximum geological information that you can infer from the magnetic anomaly.

The logical order for constraining a tabular body magnetic inversion is as follows:

- DC regional
- Position (distance) or X, Y
- Magnetic susceptibility
- Depth
- Thickness
- Dip
- Regional gradient
- Depth extent.

The azimuth and strike length are normally determined by inspection of the map. Note also that magnetic susceptibility and thickness trade off against each other during inversion and unless the body thickness is greater than its depth, it is not possible to uniquely resolve either property.
Select the **Free** button to open the Free Parameters dialog and set the **Regional Level** check box to on and then **Run** the inversion. You will see a minor shift in the regional trace.

![Inversion - Free Parameters dialog](image)

Note that the **Select Bodies** item at the top of the Free Parameters dialog is set to **ALL**. In this case, only one body exists but in more complex cases where additional bodies may be present, you can individually select the body and its free parameters. Set the Distance (position along the section), Z (depth) and Property (susceptibility) free and run the inversion. There will still be a significant mismatch in the model and field data.

Now free Thickness and run inversion again. If the Inversion Messages dialog indicates that thickness is being constrained too tightly, then you can use the Toler. Dialog to increase the constraints.

![Inversion Messages](image)
Step 9

You may need to perform a few Runs of the inversion to optimally fit the theoretical and observed response curves. If the appropriate parameters are freed sequentially, a good fit between the curves can be achieved quickly. This approach can save considerable time in evaluating even complex anomalies.

The final match between the modelled and observed magnetic responses is shown below.

*Final inverted model and response fit over the active points of the profile*
References and Further Reading


**Further Reading**


Index

Symbols

. 45

Numerics

2D polynomial 51
2D regional 17, 31
2D shapes 7
3D
   all body types 36
3D basin shapes 14
3D bodies 7
3D Model Generator 34
3D modelling environment 5, 6

A
activate lines 32
active lines 32
Active Lines button 53
Active Point 56
active point dialog 33
active point option 33
active point selection 56
active points 32
aeromagnetic sensor elevation 28
airborne survey 24
anomaly amplitude 39
asymmetry of the anomaly 39
AutoMag
   example 15
   overview 5

B
background 37
background slope 31
banded iron formations 9
barometric elevation 24
base level shift 51
basin
   modelling 14
basin sediments 48
basin structuring 13
bathymetry data 27
BMP file 48
Bouguer density 28
Bouguer gravity 28

C
CAD Characteristics 19
cgs units 22
channel
   naming 24
clipping to an area 56
Colour Lookup Tables 33
complex shapes 10
compression factor 32
Compute from Data button 53
co-sampling along lines 27
CTRL key
   use 2

datum.dat 23
datums 23
decimation 32
demagnetization 45
depth extent 39
depth to magnetic basement 15
depth to the top 40
depth-to-basement modelling 48
Desktop
   of Windows 3
dialog boxes
   for configuring 2
digital terrain model 25
dip determination 39
Display
   option described 3
downward continuation 28
drawing tools 18
drilling 46
DXF2TKM plugin 14

E
Earth's magnetic field 22
Edit
   option described 3
elevation 27
   of sensors 24
ER Mapper 23
ER Mapper grid format 26
Extrusion Wizard 35

F
facets 7
Index

File
    described 3
File>Import Data>Profiles>General ASCII Import 26
File>Project Properties 23
Filter>Convolution filters>Low Pass filter 25
    filters 47
    first vertical derivative filter 47
    fix points 54
    full 3D inversion 59

G
General Polyhedra
    cloning 10
Generate Regional Grid 54
geological inference 13
GIS
    operations 19
GPS height 24
granite 17
    modelling 17
GRAV
    channel names 24
GRAV3D
    UBC software 15
gravity units 21
Grid Utilities 28
    Classify 28
    Clip 28
    Fill Holes 28
    Flip 29
    Grid to Grid Clip 28
    Merge Grids 29
    Replace 29
    Reproject 29
    Resample 29
    Rotate 29
    Shift 29
    Split 29
    Trend 29
    Volume 29
ground level datum 24
guidelines
    for operation 2

H
half-graben 60
Help
    option described 4
high latitudes 22
high susceptibility 9
highlighted banner
    in windows 2
horizontal polygon 41

I
icon
to initiate program 3
IGRF calculator 21, 22
images 19
immediate mode 57
inclination 22
In-line filters 47
International Geomagnetic Reference Field 22
interpolate gridded data 26
interpretive and title information 19
intersection of bodies 36
introduction 1
inversion history 13
inversion 40, 57, 60
    of polygons 42
irregular boundaries
    to bodies 10

L
large data sets 32
latitude
    variation 22
layer
    modelling 12
layer densities 48
Layout Window 18
least squares fitting
    of regionals 52
limit for inversion 56
line data formats
    supported 25
Lithology Colour Coding 34
long strike lengths 13
long wavelength
    regionals 16
low latitudes 22, 38

M
MAG
    channel names 24
MAG3D
    UBC software 15
magnetic field parameters 22
magnetic latitude 38
memory
    storage 19
mines 46
Model
    option described 4
model
    definition 5
Model>Edit Regional>Magnetics 53, 55
Model>Line Control 24
Model>Magnetic Field 23
Model>Model Compression 32
ModelVision
  rules of use 2
multi-body anomalies 58
  and inversion 58
multi-body inversion 58
multi-layer basins 42
MVPROJ.INI
  file 21

N
nearby magnetic source 46
negative density contrast 14
negative gravity anomaly 49, 60
negative lobe 39
nested bodies 36

O
Oasis montaj 25, 33
objects
  and selection 2
operation
  rules 2
order
  of polynomial 52
orebodies 10
overburden 10
overlap of bodies 36

P
petroleum basins 48
petroleum exploration 13
physical property contrast 37
points
  and activity 33
polarity 39
polygon
  example 41
polyhedra
  body type 10
polynomial surface 31
practical modelling 1
print 18
printer drivers 18
Profile Analyst 15
program icon 3
project description 23
project.dat 23
projection details 21
projections 23

Q
Quick Inversion 40

R
Auto Inversion 41
  Manual Inversion 41
radar altimeter 24
reference surface 27
Regional button 53
regional control boxes 53
Regional Fixes 53
regional geological sections 13
regional gravity data 27
regional separation method 51
regionals 16, 51
regions can be activated 33
remanent magnetization 38, 39
Residual Grid 54
resolution
  of data 32
RMS
  in inversion 57
rugged terrain 59

S
satellite body detection 46
section modelling 49
sedimentary basin 60
seismic 49
sensor defaults 24
separation local anomalies 17
session file
  usage 21
SHIFT
  key usage 2
SI units. 22
single target anomalies 7
smooth inversions 15
starting models 58
strike length 7
subsetting of large ASCII files 26
synthetic data 25

T
tabular body 8, 37
  example 36
  inversion 40
target
  in inversion 60
terrain clearance 24
terrain-corrected
  gravity 28
terrain-related magnetic anomalies 30
thickness of sediments 12
TKM model files 14
toolbar 56
topographic surface 27
tutorial 62
tutorials 3
two dimensional regional 51

U

UBC tools 15
UBC-GIF 15
unconformity 36
units
    used 21
Use seed grid 54
Utility
    option described 4
Utility>Data Maintenance>Line 24
Utility>Line/Grid Sample 25, 27
Utility>Synthetic 25, 60

V

vertical gradient filters 47
views 7
volume of overlap 36

W

water column 28
Windows
    option described 4